MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Scripted tests not ending?

WebPagetest Forums

Full Version: Scripted tests not ending?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Whenever I try to run a test with scripts, the scripts never seem to end.
In this test, I had the following script:
Quote:logData 0
navigate http://www.webpagetest.org/
logData 1
setValue id=url someText
click title=Forums
All I get is, The test completed but there were no successful results.

I have a private instance of WPT 2.18 running on a 32-bit Windows 7 VM and have the same problem. I have no problems running tests through the Python batch tool without scripts. When I try using a similar simple script to the one above, I get a similar result.

The browser and seems to run through the actions successfully. When it's done though it just stays on the page without closing the browser. Eventually WPTDriver seems to time out and then the test fails. I've tried this using IE 11, Firefox 42, and Chrome 48 (all 32 bit).

Does anybody know what I'm doing wrong?
click should be "clickAndWait" so it knows it is now waiting for an action to finish.

For debugging it is usually easier to leave off the logData commands and put a "combineSteps" command at the top so you can see the full sequence that was tested and then when it is working use the logData commands to clip out the areas you don't want to record.
(01-26-2016 12:26 AM)pmeenan Wrote: [ -> ]click should be "clickAndWait" so it knows it is now waiting for an action to finish.

For debugging it is usually easier to leave off the logData commands and put a "combineSteps" command at the top so you can see the full sequence that was tested and then when it is working use the logData commands to clip out the areas you don't want to record.

Ah, that did it. Thank you very much.
Reference URL's