MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - URL issue affecting HAR, etc

WebPagetest Forums

Full Version: URL issue affecting HAR, etc
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi I've noticed a particular URL on a site seems to affect Webpagetest in a number of ways. Here's an example:

http://www.webpagetest.org/result/160217...1/details/

for the URL /us/en/multimedia/images/blogauthor/renny-shen.png?downsize=640px:*
which is request 13

If you look at request 13, and click on it to get the popup:
-Details tab, the URL is displayed wrong, it's displayed as https://www.akamai.com*

-On the request tab the URL appears correctly

-Export HAR, it affects the HAR in a number of ways,
----URL appears as GET http://www.akamai.com*
----REQUEST HEADERS in HAR VIEWER shows the extra line:
GET /us/en/multimedia/images/blogauthor/renny-shen.png?downsize=640px
* HTTP/1.1

-In the requests section of webpagetest, http://www.webpagetest.org/result/160217...#request13 , request #13 appears as https://www.akamai.com*
Looks like a parsing bug of some kind getting confused by the : in the query string. Would you mind opening a github issue so I don't lose track of it?

https://github.com/WPO-Foundation/webpagetest/issues
(02-24-2016 01:22 AM)pmeenan Wrote: [ -> ]Looks like a parsing bug of some kind getting confused by the : in the query string. Would you mind opening a github issue so I don't lose track of it?

https://github.com/WPO-Foundation/webpagetest/issues

Logged. Thanks!
Reference URL's