MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - 10 sec TTFB

WebPagetest Forums

Full Version: 10 sec TTFB
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
My Joomla 3.0 website response is very slow in the neighborhood of 15 secs. Cloudflare is the CDN.

The waterfall chart shows a 10 sec ttfb :
http://www.webpagetest.org/result/160316...1/details/


Chart: http://www.webpagetest.org/result/160316...1/details/


The host support group reviewed Mysql performance, and server logs and believes the problem may be related to a bad Joomla component or module. I created a duplicate site on a subdomain. I then uninstalled all the modules and components. The TTFB on this stripped down site is still at 10 secs.

I am not sure where to go from here. Can you offer any insights?
The waterfall will not be able to reveal much on the real cause of the high TTFB in this case. The only areas that a waterfall will help is things like bad DNS or a high connection time. You do not appear to have these issues.

Would it be possible to test a static HTML page instead of the Jhoomla setup and compare the TTFB? You could even just dump the HTML source of the home page for testing. If the problem goes away, it would indicate that there is something wrong in the Jhoomla setup itself that is causing the delay.

If the problem persists, it could indicate that there is some device at the data center (WAF, IPS/IDS) that is taking a lot of time to inspect the packets.
Did you figure this out? I noticed your TTFB is much better now?

I am having a similar issue with a wordpress install, shared hosting on windows/iis. The hosting provider put a static HTML pages in the root folder and it did not have any TTFB issues. I then asked them to create a fresh wordpress install on a subdomain, new database, and the sub-domain has the TTFB issue, although it's oddly variable. I've seen results that get under 1 second, and others as high as 8 seconds.

I'm just curious what it ended up being in your case?
Reference URL's