WebPagetest Forums

Full Version: [SOLVED] TTFB at 7s on one website (but not the other on the server)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I have a problem since a few days, the TTFB is way to long on one of my website : http://www.webpagetest.org/result/160401...1/details/
It was doing fine until two days ago, I didn't install any module or do anything (it's a prestashop 1.4.7).
And when I compare to an other website on the same server : http://www.webpagetest.org/result/160401...1/details/ it's not the same! (ok, it's not good either but not as bad as the first one).

All the cache are activated and configured in the htaccess :
<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/gif "access plus 1 month"
ExpiresByType image/jpeg "access plus 1 month"
ExpiresByType image/png "access plus 1 month"
ExpiresByType text/css "access plus 1 week"
ExpiresByType text/javascript "access plus 1 week"
ExpiresByType application/javascript "access plus 1 week"
ExpiresByType application/x-javascript "access plus 1 week"
ExpiresByType image/x-icon "access plus 1 year"
</IfModule>

FileETag INode MTime Size
<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE text/javascript
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript
</IfModule>

I couldn't find anything wrong with the database (connexions are normal, no huge table).
At this point i'm running out of idea and I need you guys... Any hint?
Well first you need to start off fixing these issues.

https://gtmetrix.com/reports/www.herbiolys.fr/d20Z6MeJ

You have 3 in the red... not a good sign. Secondly, you can defer over 100KB worth of js.. Your biggest issue is not specifying image dimensions & scaling images.

If you haven't already, move every bit of JS scripts to the bottom and have your CSS as close to the top as possible.
I ran a 9 run test and the results are not as bad as you report.
http://www.webpagetest.org/result/160404...6/details/

Even in this, the First Byte is 0.649s. The TTFB is 599s. This is your server time to generate the response. This is where you could optimize. The other tweaks could be for combining CSS and JS. However, I am not sure if you really need to spend too much time more complex optimizations since your site seems to be already fast.
Thak you for your feedback. I found the problem, it was due to the paypal module wich is checking ifthe picture are up to date, and he was doing that every time...
I juste commented the line in the code, that's why it's back to "normal".

Thaks anyway guys.
Hi anyone , My site load more than 3.8s,
I test at : https://gtmetrix.com/reports/fitnessmoti...m/CHGNhFYK
I see 2 warning :
Leverage browser caching F (12) ,
Avoid a character set in the meta tag F (40).
How to I can improve my site , Thanks anyone !
Mysite : http://fitnessmotivationtv.com/
Reference URL's