MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Issue with private test agent

WebPagetest Forums

Full Version: Issue with private test agent
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Issue with private test agent. I just recently install webpagetest as a private environment. Next I submit a request via the API which was successful however
the test is still waiting to be executed when looking at /getLocations.php.

So when I look at the logs:/var/www/webpagetest/www/ec2/log/ec2.log I see the following error

18:20:10 - Launching m3.medium ami ami-4a84a220 in us-east-1 for us-east-1,us-east-1_IE11 with user data: wpt_server=ipaddress wpt_loc=us-east-1,us-east-1_IE11 wpt_key=82f8b8cd6c6dd37d84da6403883d41bee2cf4149
18:20:10 - Error: Launching EC2 instance. Region: us-east-1, AMI: ami-4a84a220, error: No default VPC for this user

Looks like the instance is not being launched because aws is responding with an error.

What I need assistance with is to confirm if there is a param to pass to denote VPC.
(07-13-2016 04:28 AM)chancock Wrote: [ -> ]18:20:10 - Launching m3.medium ami ami-4a84a220 in us-east-1 for us-east-1,us-east-1_IE11 with user data: wpt_server=ipaddress wpt_loc=us-east-1,us-east-1_IE11 wpt_key=82f8b8cd6c6dd37d84da6403883d41bee2cf4149
18:20:10 - Error: Launching EC2 instance. Region: us-east-1, AMI: ami-4a84a220, error: No default VPC for this user

Did you set up a user in AWS with permission to create EC2 instances?
Reference URL's