MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - AWS Setting up private instance - Newbie stuck

WebPagetest Forums

Full Version: AWS Setting up private instance - Newbie stuck
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
We would like to create a public instance and then share it as a test location.

But not sure on my next step. This is what i have done so far.

Following the instructions at and create an image from AWS:
https://sites.google.com/a/webpagetest.o...-instances

I have created the following instance:
ec2-52-209-153-46.eu-west-1.compute.amazonaws.com

This is based upon you AMI:
IE11/Chrome/Firefox/Safari (2016, wptdriver only) - ami-a3a81dd0

According to the instance viewer, the server is running. Screenshot attached

I have updated the security group to allow HTTP traffic from all IP address. Screenshot attached.

Question:
1. When I try to connect to the server , and I request the administrator password, it says “This instance was launched from a custom AMI, or the default password has changed. A password cannot be retrieved for this instance. If you have forgotten your password, you can reset it using the Amazon EC2 configuration service. “. How do I login to it? What is the password?

2. What is the URL of the actual server for me to run webpagetest? When I put ec2-52-209-153-46.eu-west-1.compute.amazonaws.com or http://52.209.153.46/ into my browser, nothing happens

Many thanks in advance for your help
OK, WPT has a server and one or more agents and that AMI is for a test agent.

If you want a simple way to setup a server and agents on AWS check these docs - https://github.com/WPO-Foundation/webpag...r%20AMI.md
Hi, it comes up but just hangs.

e.g. http://52.210.130.253/result/160912_RK_2/

Any advice?

Could it be because of not adding user data when setting up? If so, do I add the user data as follows:

wpt_server=www.webpagetest.org wpt_location=Test wpt_key=xxxxx

do i still keep wpt_location as test? If not, what do i change it to?
Reference URL's