MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Unable to perform speed tests with custom script

WebPagetest Forums

Full Version: Unable to perform speed tests with custom script
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello.

I'm new here and with little experience scripting or using synthetic monitoring.

I'm trying to measure an ebook load time from several locations ans I thought that the best ways is using custom script (it needs user / pass).

I'm running this script on webpagetest.org but ebook is not loaded

Code:
setEventName loadCambridgespebooks
logData 0

// bring up the login screen
navigate https://cambridgespebooks.edinumen.es//#/es/issue/DC4909B315E34550C5096331E97FF5CC/read

logData 1
// log in
setValue id=identifiant user@domain.es
setValue id=password xxxxxxxx
submitForm name=authComponentController.loginForm

Could anyone suggest any improvement?
Generally my recommendation when using scrips is to only use the navigate and exec/execAndWait commands. That way you can get some javascript working locally in dev tools for whatever action you want to do (log in in this case) and then just use that js inside of an execAndWait command.

Generally form issues can be a bit difficult to debug if they aren't simple form submissions. The most common issue is an onclick handler on the submit button that does validation/manipulation before the actual submit happens. Using JS makes it easier to debug all of that locally first.
Reference URL's