MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - WPT Agent (ami-4a84a220) work request not seen on WPT server using SSL connection

WebPagetest Forums

Full Version: WPT Agent (ami-4a84a220) work request not seen on WPT server using SSL connection
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
1. I have configured WPT server in AWS (ami-fcfd6194). I have configured nginx to use SSL (self-signed cert).
2. WPT server sits behind load balancer. I have installed CA signed certs on load balancer.
3. THe location.ini for server is as follows:

label="Virginia agent"

browser=IE 11,Chrome,Firefox,Safari

4. Currently there is only one WPT server instance behind this LB
5. From a rest client I send a Test run request to WPT server. I see the request in the server logs and request sits in a queue with response
"statusCode": 101,
"statusText": "Waiting at the front of the queue...",

6. I configured WPT agent (ami-4a84a220) with user data
wpt_server=<hostname matching cert> wpt_loc=Virginia wpt_validcertificate=1
7. I dont see any polling work requests in the server logs. Neither am I seeing agent take on any work and requests\work being completed
8. I have tried changing user_data to wpt_validcertificate=0 and also removing it, but it still does not work
9. How do we turn on logging for wpt_driver? I dont see any logs for wpt_driver
10. We tried updating agent to latest but we get "Problem loading, trying to load settings" message
Reference URL's