MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Locations missing

WebPagetest Forums

Full Version: Locations missing
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I'm new to WebPageTest and I'm trying to set-up a Private Instance. I've followed the following guides on how to set this up from

http://andydavies.me/blog/2012/09/18/how...-instance/

but still I get no dropdowns for location and browser.

Running http://localhost:8080/?hidden=1 I can see the dropdowns

But when I run .../getLocations.php?f=html I see no locations

Below are the config for;

location.ini

[locations]
1=Local
default=Local


[Local]
1=Local-URLBlast
2=Local-WPTDriver
label=Local


[Local-URLBlast]
browser=IE 9
latency=0
label="Local - IE 9"


[Local-WPTDriver]
browser=Chrome,Firefox
label="Local"

and


wptdriver.ini

[WebPagetest]
url=http://127.0.0.1/
location=Local-WPTDriver
browser=chrome

[chrome]
exe="C:\Program Files\Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'
installer=http://www.webpagetest.org/installers/browsers/chrome.dat
;installer=http://127.0.0.1/installers/browsers/chrome.dat

[Firefox]
exe="C:\Program Files\Mozilla Firefox\firefox.exe"
options='-profile "%PROFILE%" -no-remote'
installer=http://www.webpagetest.org/installers/browsers/firefox.dat
;installer=http://127.0.0.1/installers/browsers/firefox.dat
template=firefox

Any help guidance would be appeciated
Hi, Jlaing, how do you came to this: http://localhost:8080/?hidden=1.

I'm asking because I have the same issue. Plus, running http://localhost/install my Test Locations looks like this:

Test Locations

Local_sever : Definition Missing
Public : WPT - test
Public_test : Definition Missing
Jlaing - The locations will not show up in the UI until the agents connect successfully. Is wptdriver running? Do you see the requests in the server access.log for work/getwork.php?
Reference URL's