WebPagetest Forums

Full Version: Problem with WPTDriver on Windows Server 2012R2 with Firefox and Chrome
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi everyone,

My private node doesn't work with Firefox and Chrome.

Environment:
Windows Server 2012 R2
WPTDriver 357
Webpagetest 3.0
Firefox 51.0
Chrome 56.0.2924.76

Result:
When I run test on Firefox or Chrome I get page: http://127.0.0.1:8888/blank2.html with information: "Unable to connect..."

Additional information:
WPTDriver is running as admin
Apache with webpagetest is running as admin
Everything works fine with IE11

Do you have any hint or suggestion how to fix?

Thank you in advance
Hi,

I faced such issue, I solved these issue by removing both the browser. Please follow the steps below.

1- Remove both the browser from Add Remove program.
2- Delete both browsers folder from AppData-
For Google - C:\Users\youruser\AppData\Local\Google (delete folder name google)
For FireFox - C:\Users\youruser\AppData\Roaming\Mozilla

3- Remove Registory entry for Chrome and FireFox
For Firefox- Computer\HKEY_LocalMachine\Software\WOW64Node\Mozilla (Delete Mozilla key)
For Chrome - Computer\HKEY_LocalMachine\Software\WOW64Node\Google (Delete Google Key)

4- Now change wptdriver.in file and uncomment installer line for Chrome and Firefox.

installer=http://www.webpagetest.org/installers/browsers/chrome.dat
installer=http://www.webpagetest.org/installers/browsers/firefox.dat


Restart your Computer and wait till the installation finished.

Hope this will also work for you!!!!!
First of all thank you for your reply.

Unfortunately the solution which you provided doesn’t work in my case.

In my opinion is something wrong with running by wptdriver (wpthook) of local server on port 8888 and communication between them (server ↔ browser).

On firefox I get:
Unable to connect
Firefox can’t establish a connection to the server at 127.0.0.1:8888.

On chrome:
http://127.0.0.1:8888/blank2.html
This site can’t be reached
127.0.0.1 refused to connect.

Do you have any other suggestion?

Thank you in advance.
Hi all,

I solved problem by disabling secure boot for virtual machine with windows server 2012 R2 on hyper-v.

To enable the AppInit_DLLs mechanism, secure boot has to be disabled.

Descriptions: https://msdn.microsoft.com/en-us/en-en/l...s.85).aspx
Reference URL's