WebPagetest Forums

Full Version: Trying to test login of a page but cant get past captcha
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I am trying to get some page performance metric for a website that requires login. The submit login form seems to be working but i see captcha "i am not a robot" . how can i overcome this and make sure that i am actually logged in?
I am not sure that this is possible. The point of having a captcha is to defeat automated logins.

The only safe mechanism I can think is to host an internal WPT instance. On your application, you'll have to set a rule to disable captcha for internal addresses and then script the test script.

If this is not feasible, you may want to explore turning off captcha from only WPT IP addresses and probably add some kind of an indication like a custom HTTP header. When a request is from a WPT IP and has the header, your application could drop the captcha and you can continue with the login. This is still a security hole. So please check with your teams before proceeding.
(04-11-2017 02:05 AM)akshayranganath Wrote: [ -> ]I am not sure that this is possible. The point of having a captcha is to defeat automated logins.

The only safe mechanism I can think is to host an internal WPT instance. On your application, you'll have to set a rule to disable captcha for internal addresses and then script the test script.

If this is not feasible, you may want to explore turning off captcha from only WPT IP addresses and probably add some kind of an indication like a custom HTTP header. When a request is from a WPT IP and has the header, your application could drop the captcha and you can continue with the login. This is still a security hole. So please check with your teams before proceeding.

Thanks! i was able to get it working on my private instance after disabling captcha
Reference URL's