WebPagetest Forums

Full Version: Chrome on LInux - Slow fullyLoaded time
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm experimenting with moving my WPT agents from windows to Linux but have encountered a potential blocker. Some pages are now showing fully loaded times of 30+ seconds when they were consistently ~ 3 seconds. The waterfalls show no network activity during the delay. The result is that test execution times have skyrocketed and agent throughput has tanked. Is this an issue with Chrome on Linux? Is there a way I can tell WPT to not wait so long? There is an API parameter to stop the test at document complete, but this is too soon.
(08-12-2017 06:20 AM)cpk Wrote: [ -> ]I'm experimenting with moving my WPT agents from windows to Linux but have encountered a potential blocker. Some pages are now showing fully loaded times of 30+ seconds when they were consistently ~ 3 seconds. The waterfalls show no network activity during the delay. The result is that test execution times have skyrocketed and agent throughput has tanked. Is this an issue with Chrome on Linux? Is there a way I can tell WPT to not wait so long? There is an API parameter to stop the test at document complete, but this is too soon.

Is it something you can reproduce on the Dulles Linux location? If so I can take a look and see what is going on (and fix it).
(08-15-2017 03:24 AM)cpk Wrote: [ -> ]Here is a repro
http://www.webpagetest.org/result/170814...07a93dd0c/

Were you able to look at this? Is there anything else I can provide?
(08-17-2017 03:11 AM)cpk Wrote: [ -> ]
(08-15-2017 03:24 AM)cpk Wrote: [ -> ]Here is a repro
http://www.webpagetest.org/result/170814...07a93dd0c/

Were you able to look at this? Is there anything else I can provide?

I'm out of town until Monday so probably won't get a chance to look until then.
Fixed now. The new agent was incorrectly reading the setActivityTimeout command in seconds instead of milliseconds.

One other thing to be aware of is that it doesn't look like Chrome likes navigating to about:blank. If you want to blank out the content for the video it is easier to use:

exec document.body.innerHTML='';

It looks like Chrome is popping the save password dialog in this script as well - looking to see what new hoops I have to jump through to hide it again.
Maybe not the best long-term option but until I find an easy way to turn it off globally, if you change the password field type to text when populating the form it won't get prompted to save....

exec document.getElementById('passwordControl').type='text';

(right before doing the setValue for the password).

If the login step of the script isn't logged/recorded then that will work cleanly. If you don't want to expose the password and the login IS recorded, it might be better to just make it hidden (though that changes the UI slightly).
Excellent, thank you Pat. I can see the difference in the waterfalls now. I'll work on updating the scripts with you suggestions.
Reference URL's