WebPagetest Forums

Full Version: Time To First Byte problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi everyone,

I need some help in figuring out why Time To First Byte for my website is more than 1 second. Hopefully you guys able to help me reduce it to lower time. My website results:
https://www.webpagetest.org/result/17081...50a99d62c/

I am using https://www.easystore.co/ which is like Shopify, but from Malaysia.
I am currently using CloudFlare DNS only mode.

I have tried asking the support from Easystore but doesn't help to be going anywhere on the problem.

Any help is appreciated! Thanks Smile
You needed to disable cloud-flare. some time is make TTFB slow.
In this case it's not a cloudflare or proxy issue since it is in DNS-only mode and that is not where the time is going. The 800-900 ms server response time is entirely in easystore's hands and unfortunately there isn't anything you are going to be able to do about it except for switching platforms unless their tech team is willing to investigate and optimize performance.
Thanks Patrick for the info. I have been trying to reduce the Time to First Byte with little luck. I'll try to get the easystore team to investigate on this if possible.

Thanks once more Smile
As an aside, I wouldn't use tools who think that mail can't be delivered unless a MX record it set if I were you!
As Patrick suggested, get rid of CloudFlare.

Coarse testing I did with curl shows very slow response from CloudFlare, which is typical.

After you've removed CF, retry your testing.
Reference URL's