WebPagetest Forums

Full Version: HTTP/2: webfonts, .png, .jpeg result in 404
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

Not sure this is a Webpagetest bug, but as the website is loading well within 2-3 seconds, I presume so.

I tweaked a Wordpress website to load within 2.3 seconds, improving load speed from the former 5 seconds. Webpagetest.org server is at Los Angeles and website server is at Los Angeles.

With everything running fine, as a last tweak, I enabled HTTP/2 on the LAMP (Apache 2.4, PHP 7.0) server.

On enabling HTTP/2, the Webpagetest.org will tell me that Time to First Byte is now F (from A), and all the website images and webfonts result in 404. Website load is over 19 seconds. I disable HTTP/2 and Webpagetest.org will work properly. See screenshot here https://www.diigo.com/item/image/5pj5q/y75a

I could not find any information about issues between HTTP/2 and .png/.jpeg images. Is this an issue with Webpagetest.org?

Any advice is welcome.

Rgs

IM
No, WebPageTest is used to test HTTP/2 sites all the time and there are no known issues. Does the site work when HTTP/2 is enabled and you try loading it in Chrome or Firefox?
Hi pmeenan, thank you.

Yes, the website loads well on Chrome. I sent you the website through PM.

Please, could you check from your side?

Rgs


(11-18-2017 12:37 AM)pmeenan Wrote: [ -> ]No, WebPageTest is used to test HTTP/2 sites all the time and there are no known issues. Does the site work when HTTP/2 is enabled and you try loading it in Chrome or Firefox?
So to confirm, if you enable http/2 the website appears ok to you but there are errors as far as webpagetest is concerned?

When you enable http/2 have to tried to view the site on your pc in a new incognito window to load it fresh with no cookies or cache? I would also suggest trying to load one of the 404 resources directly as a url in a new incognito window and enter the resource's url into webpagetest.org to see if just access the single resource works or not.
Reference URL's