WebPagetest Forums

Full Version: YOUR FEEDBACK ON MY PROJECT
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
Thanks in advance for spending your valuable time to read this message.

I recently developed a new tool at perfhack.com to test any website performance across all devices i.e desktop, laptop,tabs and mobiles.

Some of the functionality of this tool depends on webpagetest.org private agents.

If you don't mind, can you please give me feedback about perfhack.com ?

Both positive and negative feedbacks are highly welcome.

thanks
- missing detailed info where servers are located, "Asia" is tooo general
- when form submitted I'm on page https://www.perfhack.com/report with text "Tests may take sometime depending upon load. You can come back to this page after sometime to see the results.". Is it session based? Change that page link to https://www.perfhack.com/report/session_id because I regularly delete session.
- what you mean by "Load Time", dom content loaded, on load or first bite - add explanation
- too much "same circles" in detailed report
- under "STATISTICS AND WATERFALL (FIRST VIEW AND REPEAT VIEW)" html per request returns "undefined"
Thank you very much for the feedback jasom. Yes, most of the things you said were true. I will correct them sooner.
But i did not understand "STATISTICS AND WATERFALL (FIRST VIEW AND REPEAT VIEW)" html per request returns "undefined" ?
Normally it take time to load waterfall. Did you see any error message while loading ?
As part of the UI, you ask for 'Website Name' when what you really want is 'Website URL'.

Also, because the name of the field is 'in the field' you should add the field name as soon as the user focuses on that field (as a best practice).

Lastly, you provide some different connection devices, but you don't explain the differences--I'm assuming they provide different speeds. If that's the case, you should specify what the speeds are, as that is far more important than the connection name.
* Just ran a test, it looks like your tool can't detect Brotli compression.
* I'm using cloudflare, it failed to detect that as a CDN
* I put in https://www.vgchat.us/forum/forum.php (https) and it complained that the http version redirected to https (when I didn't test the http url).
Reference URL's