WebPagetest Forums

Full Version: [split] How to set up mobile testing with simulator
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,
I am also facing the same problem.
Following are my test parameters
values = {
'fvonly' : 1,
'f' : "xml",
'runs' :1,
'requests':1,
'mobile' :1,
'mobileDevice' :'MotoG4',
'bwDown': 768,
'latency': 300,
'location':'private instance'
}

I want to set up connectivity details like bwDown and latency, but when I run the tests it runs with cable connection
@target, I'm splitting this off to a separate thread because it has nothing to do with running inside of an Android or iOS simulator.
My guess is that it is the location string which needs to have the connectivity (and browser) in it and the connectivity needs to be 'custom' if you are going to explicitly define bandwidth and latency settings instead of using a preset. It is using Cable because that is the default if nothing else is specified.

'location': 'Dulles:Cable.custom'
Reference URL's