WebPagetest Forums

Full Version: New website is slow. First Byte Time = F
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

I'm new to this forum. We have a month-old website, built on WordPress, hosted at SiteGround. It's slow...especially the home page.

Here are the test results:
https://www.webpagetest.org/result/18030...7247db234/

First Byte Time gets an F. How do I improve that grade? Is that a hosting thing, or a WordPress thing?

Thanks,

Mark
Here you go, my recent article can get you started.
https://www.vbulletin.org/forum/showthread.php?t=326118

Code:
RewriteEngine on
  #Options +FollowSymLinks
  ################https##############
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
  ################https##############

That will help with speed, also you can have cloudflare cache. I suggest for 20 days or more.
Hi Avalanch,

Thanks for this information. To summarize your advice, you're suggesting that there are instances in the Wordpress code that are using "http" instead of "https" and the code provided will change these instance to "https". Is that correct? Is this a big contributor to the slow First Byte Time?

You are also recommending that we set the Cloudflare cache to 20 days or more.

Any other recommendations would be greatly appreciated.

Thanks,

Mark
Yes doing that will change your http links to https. There are 5 big benefits you can gain from doing this (cited in the article) and you'll be able to use Brotli via cloudflare. You should start to notice a big difference in your tests after you do this.

I don't use wordpress but the more external scripts you have, the higher the load time will be. You can use gtmetrix to see more details on potential issues. https://gtmetrix.com/reports/www.directe...m/oQ5B6fUD

Oh and to avoid mixed content warnings put this in your header.

Code:
<meta http-equiv="Content-Security-Policy" content="upgrade-insecure-requests">

More info here https://developer.mozilla.org/en-US/docs...e-requests

Also you should try to host this locally
https://fonts.googleapis.com/css?family=...A400italic

Along with all of the woff fonts that it calls
Reference URL's