MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - High TTFB & Security issue

WebPagetest Forums

Full Version: High TTFB & Security issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am getting high TTFB for my wordpress site. And a security error.

I am new to wordpress and web development, can anyone please point out the cause of the issues?

https://www.webpagetest.org/result/20070...5fa899d3c/
I'm no expert but I'll take a stab at this;

Firstly security. If you click on the big red F, it will open the page below. Then you'll need to follow the recommendations. If you are running wordpress, the jquery is a false positive because they back port security fixes but the other items should be addressed.

https://snyk.io/test/website-scanner/?te...te-scanner

Next, you need to look for render blocking script. If you have script blocking the render of your page, it's going to take a while. I'd also be searching for any third party code and try and load it in the footer. If you have a lot of plugins, try to reduce the amount and only use the ones that you absolutely must have.

That's nowhere near comprehensive but I bet you it is a good start. Lastly, use a good plugin to optimize your css & js. I would suggest you check out autoptimize which is a fantastic WP plugin.

Good luck.
1) No Malware detected on your site.

2) Best to upgrade to PHP-7.4.8.1 just to be safe. You'll have to check release notes for security items.

3) The long time required to serve your HTML relates to your database.

Since you're running WordPress, best first step is to run mysqltuner + implement suggested fixes.

This will resolve many or all problems related with generating + serving your HTML component.
Reference URL's