MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - --shaper none option does not work

WebPagetest Forums

Full Version: --shaper none option does not work
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
Was trying to use the "--shaper none" option when starting my Dockerized agent, but getting an error:

docker run -d -vvv -p 4001:80 --network="host" --shaper none -e "SERVER_URL=http://localhost:4000/work/" -e "LOCATION=Test" webpagetest/agent

unknown flag: --shaper

Am I missing anything?

Thanks,
Tim
Hi Tim!

--shaper is a parameter of wptagent, not of docker, so it should be added to the EXTRA_ARGS environment variable inside the docker -e option, so it gets passed to wptagent at startup. For example:

Code:
docker run -d -vvv -p 4001:80 --network="host" -e "SERVER_URL=http://localhost:4000/work/" -e "LOCATION=Test" -e "EXTRA_ARGS=--shaper none" webpagetest/agent

I hope that it helps!
Thanks very much, that worked.

Tim
Reference URL's