MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Hosted PageTest (Virtual Machine) Issues

WebPagetest Forums

Full Version: Hosted PageTest (Virtual Machine) Issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Shouldn't be - doesn't use .net at all....hmmm. Glad to hear it's working though.
(03-03-2010 10:30 AM)Aaron Wrote: [ -> ]Thank you.... No it is not critical to correct the bug immediately. However, I seem to still have a problem which I observed, but could not confirm until I had the port issue solved (see below).

One additional question:
Is the rapid window closure normal for win32 binary? Where is the data stored prior to being transmitted to the server or is it simply held in memory and dumped?

Creating the iptables redirect solved this issue (there is no rush to deliver a fix) but there is definitely something wrong with timing methods on a virtual machine (XP) because I can assure you (I am watching the running VM on my Mac live) that the execution time was <2-3 seconds to open and then close the window. IE works fine when run manually and there are no browser errors. However, the test server is reporting that it timed out after a negative time duration. Suggestions? How are the current publicly available pagetest test nodes provisioned? As VMs or dedicated hardware? The screenshot shows Internet Explorer cannot display the web page... The results are below:

Results for '':

Error loading page: -2146697213 (0x800C0003)
Page load time: 523.956 seconds
Time to first byte: 0.000 seconds
Time to Start Render: 525.548 seconds
Time to Document Complete: 523.956 seconds
Time to Fully Loaded: 523.956 seconds
Bytes sent out: 0.000 KB
Bytes received: 0.000 KB
DNS Lookups: 0
Connections: 0
Requests: 0
OK Requests: 0
Redirects: 0
Not Modified: 0
Not Found: 0
Other: 0

Hello there,

i'm getting the exact same error message/log output on my instance (Windows XP/ IE8). I think this is a physical box, not a VM, i'm on it using remote desktop.

When disabling the CIEhook i can at least use the browser, with this addon active nothing works - it seems.

i'm using webpagetest-2.2.

Any suggestions?
Do you have any antivirus installed? If so, which one? I have seen conflicts with the "web shield" part of some antivirus solutions.

If you are having issues with getting IE working with the browser plugin you can uncomment the browsrExe=pagetest.exe line in loactions.ini on the server and it will switche to use a dedicated browser (with the IE engine). The main difference is that it doesn't load any other plugins that you have installed so it avoids any compatibility issues.
That did it! Now i can at see that its working and i get summarized results. The waterfall is empty though. There is no content breakdown, but the screenshots are there. I'm using php as a module on windows apache, maybe there is a problem with the gd module...
Are the screen shot thumbnails there? If so then it's probably not a gd problem (gd is used to generate those as well). Can you check the error.log on the apache server to see if there is anything useful in there? Maybe a memory limit being hit or something.
Wow, you have got very short response times Smile

Yes, silly me, php.ini has an invalid default dir for extensions, strange. after fixing that i can see the waterfall!

Looks like everything is perfect now. Great tool. Thank you very much!

Will try to get video capture running, but the crucial stuff is perfect allready.
Pages: 1 2
Reference URL's