MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Pop-ups not blocked with pagetest.exe

WebPagetest Forums

Full Version: Pop-ups not blocked with pagetest.exe
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Pat

I'm having the issue where pop-up windows are not closed by pagetest.exe.

Is there a way I can force pagetest.exe to not spawn pop-up windows? Because all these IE windows that pop-open is causing a memory hog.

My test machines are running Win Server 2003. I'm currently still on version 1.6, I'm looking to move up to 1.8, but would that solve the problem?

Thanks
D.
Try at least updating urlblast and pagetest.exe to the latest builds. It is supposed to block popups as well as terminate any child processes that get spawned but every now and thin it looks like there are some sites that even manage to bypass those protections.

If you have a failcase page that manages to get pop-ups through the protections please send it my way and I'll get it taken care of (send it to pmeenan@webpagetest.org).

Thanks,

-Pat
(05-31-2010 11:36 PM)pmeenan Wrote: [ -> ]Try at least updating urlblast and pagetest.exe to the latest builds. It is supposed to block popups as well as terminate any child processes that get spawned but every now and thin it looks like there are some sites that even manage to bypass those protections.

If you have a failcase page that manages to get pop-ups through the protections please send it my way and I'll get it taken care of (send it to pmeenan@webpagetest.org).

Thanks,

-Pat

Hi Pat

I've updated to the latest build, but the pop-ups still creeps in. I'm solving it by running a vbs script to kill any iexplorer.exe process created by user1. Seems to solve the problem of getting rid of the windows.

Since you asked, an example of the failcase is the homepage for http://www.silicon.de which pop-up a small survey window. But I have not been able to consistently re-create it on my desktop's IE, it only pop-ups when it's tested by WPT. Might be a cookie thing.
Thanks, the failcase helped. Apparently I was closing everything except for iexplore processes (didn't want to accidentally nuke a browser being tested). I just put some code in to close ALL processes owned by the testing account after each browser test. Initial testing looks good - I want to do a little more testing and then I'll put it up for download.

This is a problem we've been having periodically on the public testers as well so getting it nailed will really help.

Thanks,

-Pat
If you just want the updated binaries you can get it here: http://www.webpagetest.org/software/pagetest_222.zip

I also did a full new release of the hosted site code (which includes the dynamic bandwidth support as well as the popup fixes) here: http://www.webpagetest.org/forums/showth...hp?tid=235

Thanks,

-Pat
Thanks Pat!
Reference URL's