MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Cannot auto open Chrome on Test Agent

WebPagetest Forums

Full Version: Cannot auto open Chrome on Test Agent
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I set up Test Agent to test with Google Chrome, but chrome cannot open automatically. Here is my wptdriver.ini:
Code:
[WebPagetest]
url=http://127.0.0.1/work/
Location=Test_Chrome
Location Key=TestKey123

[chrome]
exe="C:\Documents and Settings\tester\Local Settings\Application Data\Google\Chrome\Application\chrome.exe"
options="--load-extension=C:\webpagetest\extension --user-data-dir=C:\Documents and Settings\tester\Local Settings\Application Data\Google\Chrome\User Data\Default\Cache --new-window --no-proxy-server --no-first-run --no-default-browser-check"
cache=C:\Documents and Settings\tester\Local Settings\Application Data\Google\Chrome\User Data\Default\Cache

and my settings.ini:
Code:
[locations]
1=Test_loc
default=Test_loc

[Test_loc]
1=Test_Chrome
2=Test_IE
default=Test_Chrome
label=Test Location

[Test_IE]
browser=IE 7
;browserExe=pagetest.exe
latency=0
label="Internet Explorer 7"
;key=TestKey123

[Test_Chrome]
browser=Chrome
latency=0
label="Chrome"
key=TestKey123

Please tell what's wrong in my configuration.
Thanks!
Couple of items with the wptdriver.ini:

1 - remove the work/ from the URL. Unlike urlblast.ini, it is not needed, just the base URL for the server.
2 - For the user data dir and extension parts of the command line, leave the %WPTDIR% and %PROFILE% strings from the original, they will be expanded automatically
3 - You shouldn't need the cache= line (as long as you use %PROFILE% for the user_data_dir).

I'm assuming the path to the chrome exe is correct (I expect #1 was the main problem)

Thanks,

-Pat
Hi Pat,
Here is my wptdriver.ini file after changing:
Code:
[WebPagetest]
url=http://127.0.0.1/
Location=Test_Chrome
Location Key=TestKey123

[chrome]
exe="C:\Documents and Settings\tester\Local Settings\Application Data\Google\Chrome\Application\chrome.exe"
options="--load-extension=C:\webpagetest\extension --user-data-dir=C:\webpagetest\chrome_cache --new-window --no-proxy-server --no-first-run --no-default-browser-check"
I'm sure about path to Chrome exe is correct (cuz chrome set up on default path), but it doesn't still work.
sorry, one more change - in wptdriver.ini it should be "Key=", not "Location Key=". Sorry for changing the names from urlblast.ini but we were taking the opportunity to try to make things a little cleaner on the new platform.
Yeah, brilliant! It's exact I need. Thanks so much Pat!
Now, it works ok with Chrome, and shows the results right. But when I click "Create video" button, it cannot create video, just staying the "Video will be create shortly" screen. (When I change to use IE for Test Agent, creating video is ok).
Do we need any plugin for creating video when using Chrome for Test Agent?
Are the IE and Chrome agents connecting to the same server (you can run both wptdriver and urlblast at the same time, they will make sure only one is running a test at a time)?

Only urlblast knows how to render videos right now so you need at least one instance of it running, even if it isn't connected to a location. The videos can be rendered by any location it doesn't need to be the same one that ran the test.

Thanks,

-Pat
So amazing, I have just tried your solution. It works perfectly right now.
Big thank for you, Pat.
Reference URL's