WebPagetest Forums

Full Version: LABjs messing up waterfall charts?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Today i thought I found an issue with LABjs which seemed to effect IE8.

The supposed issue was that there was a delay in start downloading of each javascript file as shown by the waterfall chart see requests #8 to #13.

But when i see the tcp dump in wireshark, and filtering by :
Code:
http.request.method == "GET"

I see the order is different than in the waterfall chart, and happen very rapidly as expected....

This issue is not seen on IE7 and IE9 test agents... Any pointers?
Sajal,

have you ran tests with other IE8 boxes on Webpagetest.org?
Do they show a different waterfall?
Looking at the waterfall and the TCP Dump, it looks like the http requests are issued to WinInet around the same time but the DNS lookups are serialized and it doesn't process any of the connections until the sequence of DNS lookups completes (which is why the http requests look like they go out on the wire at the same time). It's actually something I've seen before with IE8.
The sequential DNS lookups is not typical for IE8. In other words, it certainly does *not* always happen in IE8, but apparently sometimes it happens. Question is: what causes the lookups to happen sequentially? You can see in the waterfall further down that other lookups actually take place in parallel...

Note: I believe DNS lookups *do* always happen sequentially in IE7.
err.... i should have filtered : udp.port == 53 to get a clearer picture... my bad.

im very puzzled with the sequential DNS lookups... cant figure out any sane reason for it. DNS doesn't consume any significant bandwidth.. (perhaps its just being IE-ish)

@aaron both IE7 and IE9 handle it well as expected

So... a user 300ms away from DNS server would take seconds to load the javascripts? (testing again with artificial lag)
Sajal,

my previous statement about IE7 was wrong. I should have written: IE7 on Windows XP always does DNS lookups sequentially. Apologies.
Test your page on the Amsterdam IE7 box, that runs on Win XP.

Patrick > can we somehow know what OS is running on each test machine?
(03-01-2011 02:02 AM)aaronpeters Wrote: [ -> ]Sajal,

my previous statement about IE7 was wrong. I should have written: IE7 on Windows XP always does DNS lookups sequentially. Apologies.
Test your page on the Amsterdam IE7 box, that runs on Win XP.

Patrick > can we somehow know what OS is running on each test machine?

hmm... the amsterdam ie7 box is doing 2 lookups at a time http://www.webpagetest.org/result/110228...1/details/ better than the Dulles ie8 box at least.

Just read your interesting blogpost about it .

I ran the test again on Dulles IE8 this time using 350ms latency.
http://www.webpagetest.org/result/110228...1/details/

It seems with higher latency it is parallelizing(to some extent)?
FWIW, all of the Dulles browsers except for IE9 are running XP. I'll see about getting the OS information sent up from the test machines automatically.
Hmm ... on this page, the IE7 on Win XP is *not* doing the lookups sequentially. And so, my blogpost needs an update (luckily, the post is hidden really well ;-)


My original test page now shows inconsistent behavior on the IE7-WinXP box:
http://www.webpagetest.org/result/110228...c21432676/
(03-01-2011 02:15 AM)aaronpeters Wrote: [ -> ]Hmm ... on this page, the IE7 on Win XP is *not* doing the lookups sequentially. And so, my blogpost needs an update (luckily, the post is hidden really well ;-)

first result at http://www.google.com/search?q=internet+...ns+lookups

not exactly well hidden Wink
Pages: 1 2
Reference URL's