WebPagetest Forums

Full Version: Private Instance Problems
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I recently tried to set up a private instance of webpagetest and have run into an issue. I set up a copy of WAMP to run the server on a Windows 7/32bit box and installed urlblast on the same box. Urlblast fires up and I can reach the server and set a test to run, but it sits in the queue waiting to be tested. The log files of urlblast seem fine, and it sits up in the corner "Running..." but IE does not fire and tests are not being run.

Can you point me in the right direction as to what I may have missed?

Thanks
Keith
Does the location and location key match between the server (locations.ini) and agent (urlblast.ini)? If you tweaked the locations.ini on the server but didn't make the corresponding change to urlblast.ini that would explain it.

Otherwise the investigation would basically follow:

- Look in the <document root>/work/jobs/<location> folder on the server and make sure the job file is there (should be if it is being marked as being at the head of the queue)

- Check the access logs for the work/getWork.php calls to make sure the server is seeing the requests from urlBlast and make sure the location in the requests matches the directory name

Beyond that it's possible to turn on more debugging but probably not worth it because most other conditions would result in the test having "started" and just never complete.

Thanks,

-Pat
Hi Pat,

Thanks for the help. I checked the location key, and they match up. I haven't tweaked them at all.

I looked in the jobs folder and there is a shortcut file in there to the job waiting in the queue.

I took a look at the log files for the getwork.php call and came up with this:

192.168.252.78 - - [04/Mar/2011:16:33:29 -0600] "GET /getwork.php?location=Test&key=TestKey123&pc=WINVMSRVR-1202&ver=261 HTTP/1.1" 404 209

The getwork.php file is in the work folder and not in the root as this line seems to imply. I am not sure if this is at all helpful.

Keith
Can you shoot over your urlblast.ini file (url files url line in particular). The default is http://127.0.0.1/work/ (if you modified it to change the host name and stripped off the /work/ it could explain what you're seeing.
That was exactly the problem. Thanks. I have it up and running nicely.

Keith
Reference URL's