MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
WebPagetest Forums - Chrome and different versions of IE

WebPagetest Forums

Full Version: Chrome and different versions of IE
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm having a hard time getting Chrome to run on my private install. I followed the instructions here: https://sites.google.com/a/webpagetest.o...TOC-Chrome

But am unable to get Chrome to show up in the drop down menu. Also, how do I make Chrome the default and not IE?

My second questions is about IE. The test machine that we are using to run the private install (win xp) has a couple versions of IE on it (We use it for testing layouts) Is there a way to select which version of IE we want to use to run the tests?
What does your locations.ini look like? The dropdown is completely driven from that (take a look at the sample and make sure you have an entry for the Chrome location).

As far as IE goes, it doesn't support side-by-side IE installs and just runs the default IE for the OS. I haven't had a chance to look carefully enough at the side-by-side installs yet to be comfortable that they are accurate (my main concern is if they use the correct lower layers - wininet, etc - for a given browser so that the network requests are also accurate and not just the renderer).
Thank you for your reply you do a very good job replying to people here. I've gone through and made some edits (I was looking at the 1.1 locations.sample file) I ended up getting the chrome frame to work correctly but not chrome alone.

I now see chrome and IE as an option but nothing happens when I choose Chrome. I'm going to go back through the steps and hopefully figure out why it's not working.

Here is my locations.ini file:

[locations]
1=Test_loc
default=Test_loc

[Test_loc]
1=Test_IE
2=Test_Chrome
default=Test_Chrome
label=Test Location

[Test_IE]
browser=IE 7
;browserExe=pagetest.exe
latency=0
label="Internet Explorer 7"
key=TestKey123

[Test_Chrome]
browser=Chrome
latency=0
label="Chrome"
key=TestKey123
For Chrome you need to run wptdriver.exe (and configure wptdriver.ini with the path to the chrome executable - usually just copied from the shortcut to chrome from the desktop).

URLBlaster and wptdriver can both run in parallel on the same system (they make sure that only one is actively testing at a given time) but for right now it takes 2 different executables to test the different browsers.
Reference URL's