WebPagetest Forums
Wrong user agent used on Montreal, Canada - IE8 - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Wrong user agent used on Montreal, Canada - IE8 (/showthread.php?tid=10987)



Wrong user agent used on Montreal, Canada - IE8 - rbhogi - 04-13-2012 04:02 AM

I have selected Montreal, Canada - IE8 as user agent and when I run the test, I am seeing user agent as "User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.2; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E; PTST 2.318)" in the test

http://www.webpagetest.org/result/120412_HY_3Y264/1/details/

Looks like configuration was wrong. In the test it's showing as IE7 but I selected IE8

Thanks,
Raja


RE: Wrong user agent used on Montreal, Canada - IE8 - pmeenan - 04-13-2012 04:46 AM

It looks like ebay.com was on the compatibility list for a while (not sure when it got removed) but I just ran a test from the same server for aol.com and the headers look correct: http://www.webpagetest.org/result/120412_F6_ece936f472ff7091266171fecca975cf/1/details/#request1

I verified that both tests ran on the same physical machine so IE's compatibility view is my best guess.

I'll see if I can remote into the machine to make sure it has pulled down all of the compatibility view updates.


RE: Wrong user agent used on Montreal, Canada - IE8 - rbhogi - 04-14-2012 03:18 AM

Thanks Patrick
I am seeing similar behavior For Asheville, NC - IE8 - FIOS

Selected IE8 and header are showing IE7.

http://www.webpagetest.org/result/120412_XQ_3Y9VV/

Thanks,
Raja