WebPagetest Forums
Configuring a relay server - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: Configuring a relay server (/showthread.php?tid=11355)

Configuring a relay server - nikosd66 - 06-20-2012 07:42 AM

I have setup an instance of WebPageTest 2.4 in an all-in-one windows 2008 r2 server and everything works perfect.
I have also setup a linux server as a web server and it works perfect with the windows 2008 server as Test machine.
Now I'm trying to setup the Test machine (windows server) to act as a relay server for linux server.
Whenever I submit an url for testing from Linux server I get the error:
"Error submitting url for testing".
I've tried every possible combinations in location.ini and urlblast.ini with no luck.

What am I doing wrong?

RE: Configuring a relay server - pmeenan - 06-21-2012 03:14 PM

I'm pretty sure you shouldn't be trying to set up relay with 2.4. You need 2.5 at a minimum but 2.6 fixed some bugs and would be a safer bet.

RE: Configuring a relay server - nikosd66 - 06-22-2012 05:27 AM

I installed 2.5. Unfortunately I run php 5.2.xx and can't run version 2.6.
Anyway still no success with v 2.05.
I believe that my location.ini files are not setup properly. I probably don't know where to put relaykey, relaylocation and/or localdir
The error is:
"Relay: Sorry, that test location already has too many tests pending. Pleasy try again later."

I would appreciate an example of location.ini files for all servers involved, for the following cases:

Case 1
www server1 -> linux (only www)
relay server2: All in one (www+test agent) in a windows server

Case 2
www server1 -> linux (only www)
relay server2 -> linux (only www)
test machine -> windows server3

I've tested successfully all three server combinations if no relay exists.
I'm realy comfused.Sad

Thank you

RE: Configuring a relay server - nikosd66 - 06-24-2012 02:42 AM

Well, I found what the problem is. It has nothing to do with location.ini configuration.
In runtest.php and in RelayTest() function, there is the line:
$test = json_decode($_POST['testinfo'], true);
If we run php<5.4 and magic_quotes_gpc is enabled in php.ini, then we have a problem.
To overcome this, I added a line of code just before:
if (get_magic_quotes_gpc()) $_POST['testinfo'] = stripslashes($_POST['testinfo']);

Now everything works fine.