WebPagetest Forums
Please Excuse my ignorance - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Please Excuse my ignorance (/showthread.php?tid=11494)



Please Excuse my ignorance - Nolove28 - 08-01-2012 12:55 PM

The test result is like another language to me. My wordpress site is super slow especially at loading images. Being that I have a bunch of F's I would figure that like in school this is not good. My host provider is Arvixe. What else would I need to provide to help diagnose my issue?

Here are my test results for whoever has the time to help me out.

http://www.webpagetest.org/result/120731_PK_24R/

Thanks for any help.

Art


RE: Please Excuse my ignorance - pmeenan - 08-02-2012 04:26 AM

The grades are something that needs to be fixed and is a mix of things you hosting provider needs to do (gzip and keep alive) and stuff that is in your control that something like W3 Total Cache can help with (first byte time and cache static content).

That said, by FAR, the biggest problem is the amount of time it takes to generate the thumbnails. If you look at the waterfall: http://www.webpagetest.org/result/120731_PK_24R/1/details/

Each row in the waterfall is a request that the browser makes to your server in order to build the page. The 4 REALLY long green lines that take 20 seconds each are calls to generate thumbnail images dynamically. Either that is broken entirely or it's having to operate on enormous images. Either way, fixing the thumbnail generation should be near the top of your list.


RE: Please Excuse my ignorance - Nolove28 - 08-02-2012 06:17 AM

Thank you very much for looking at my report. The nail generation is this something that I'm supposed to fix or Arvixe which is my web host? Should I just send them my report and say you need to help me out and fix this?


RE: Please Excuse my ignorance - pmeenan - 08-02-2012 06:27 AM

The thumbnail generation is for whoever built your wordpress site to fix. It's not a problem with the hosting.


RE: Please Excuse my ignorance - Nolove28 - 08-02-2012 06:54 AM

Ok thank you.


RE: Please Excuse my ignorance - Nolove28 - 08-15-2012 02:55 AM

Ok I was told to optimize all of my images which I did however my site is still slow. Not sure what a CDN is but I must not have one because I didn't receive a grade for it.

As for the PHPthumb I checked with the Wordpress theme Admin and he stated that it was disabled so why is it still taking so long to load my website?

Here is my new test results:

http://www.webpagetest.org/result/120814_14_RZE/


RE: Please Excuse my ignorance - pmeenan - 08-15-2012 12:11 PM

The site is still trying to call phpthumb (and failing). If the theme admin disabled it he didn't do it properly.