WebPagetest Forums
Cache static content - Help With The Code - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Cache static content - Help With The Code (/showthread.php?tid=11935)



Cache static content - Help With The Code - jordan6 - 12-09-2012 05:42 AM

When I tested my site I got all "A" except for the Cache Static Content which was "F".
It changed to "D" when I added the following code:

<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/gif A31536000
ExpiresByType image/jpg A31536000
ExpiresByType image/jpeg A31536000
ExpiresByType image/png A31536000
ExpiresByType image/bmp A31536000
ExpiresByType text/css A31536000
ExpiresByType text/javascript A31536000
ExpiresByType application/javascript A31536000
ExpiresByType application/x-javascript A31536000
</IfModule>

However I still need it to be "A".

I also have "Header set Expires":

<FilesMatch "\.(ico|pdf|flv|jpg|jpeg|png|gif|bmp|js|css|swf)$">
Header set Expires "Wed, 31 Dec 2014 20:00:00 GMT"
</FilesMatch>

Any ideas where I go wrong or what do I need to change?

I'm using MaxCDN if it matters.
Thanks


RE: Cache static content - Help With The Code - pmeenan - 12-11-2012 07:01 AM

Can you link to the results? If you click on the grade it will give you a list of the resources that failed - maybe it will be clear that a specific mime type failed or something like that.