WebPagetest Forums
Please help and explain regarding my website load time issue.... - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Please help and explain regarding my website load time issue.... (/showthread.php?tid=12082)



Please help and explain regarding my website load time issue.... - dearbuddy - 03-03-2013 09:42 PM

Hello,
We are developing an php news portal website and have almost completed it. But we are facing issue with the loading time of it, as it takes too much time to get loaded fully and the first byte time is also too high. The website we are making is unicode.akilanews.com and its webpagetest.com test result can be seen at http://www.webpagetest.org/result/130303_1J_9P6 .
So,can anyone out here please guide us as to what should be done to overcome this issue we are facing or can point out the problem there might be with our website??
My website is hosted on a knownhost.com VPS , and we are using customised cms and php platform.
Thankyou in advance for the help we get from you...... Smile
Nimish.


RE: Please help and explain regarding my website load time issue.... - pmeenan - 03-05-2013 07:35 AM

Wow - that is a crazy first byte time. Something in your customized CMS is to blame (calls to an external service, database or something along those lines). We can't tell what is going on from the outside but if you install something like New Relic it will tell you what is taking so long on the back-end.


RE: Please help and explain regarding my website load time issue.... - xpert - 04-01-2013 03:37 PM

(03-03-2013 09:42 PM)dearbuddy Wrote:  Hello,
We are developing an php news portal website and have almost completed it. But we are facing issue with the loading time of it, as it takes too much time to get loaded fully and the first byte time is also too high. The website we are making is unicode.akilanews.com and its webpagetest.com test result can be seen at http://www.webpagetest.org/result/130303_1J_9P6 .
So,can anyone out here please guide us as to what should be done to overcome this issue we are facing or can point out the problem there might be with our website??
My website is hosted on a knownhost.com VPS , and we are using customised cms and php platform.
Thankyou in advance for the help we get from you...... Smile
Nimish.
This long ttfb is surly issue with server, db queries. To catch the real bottleneck try profiling your code in sections. Enabling slow query log for mysql on production and development will help. There might be only few functions/queries which are causing this issue.