WebPagetest Forums
How to fix keep-alive and cache staticdsadas - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: How to fix keep-alive and cache staticdsadas (/showthread.php?tid=12104)



How to fix keep-alive and cache staticdsadas - Bloemenman - 03-12-2013 06:04 AM

Hi,

I have a question. How can I fix the problem on row 1: Activate keep-alive on the https redirect? And the Cache static on this redirect?

The second question is if it's possible to get cache-static on the external js file? See screen for row 19.

http://www.webpagetest.org/result/130311_HZ_15F9/1/performance_optimization/#first_byte_time

Thxz in advance.

Screen + link addes.
[attachment=267]


RE: How to fix keep-alive and cache static - andydavies - 03-12-2013 06:52 AM

Think you forgot to add in a link to the test :-)


RE: How to fix keep-alive and cache static - Bloemenman - 03-12-2013 07:49 AM

Update Smile Screen + link


RE: How to fix keep-alive and cache static - andydavies - 03-12-2013 10:12 PM

Request 1:

Response returns "Connection: keep-alive, close" I would suspect this is the cause - some other responses return "Connection: keep-alive, Keep-Alive" and some just "Connection: Keep-Alive"

I'd look at why you've getting the multiple options set for Connection.

Request 19:

This is hosted by someone else and so out of your control, reason it's not cached it "Cache-Control: max-age=0, private, must-revalidate"

I'd always run more than one test as the SSL negotiation looks horrible in that test but not too bad on tests from Dublin.

You may be able to improve the SSL performance by merging the intermediate certificates in.