WebPagetest Forums
WPT private instance waterfall error - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: WPT private instance waterfall error (/showthread.php?tid=12209)



WPT private instance waterfall error - jujaehrig - 04-24-2013 01:08 AM

I always have a beam in my waterfall-charts.

I tried it:
- with wpt 2.10 and 2.11
- on xampp 1.7.4
- and debian-squeeze

So the bug seems to be in the wpt-code which creates the chart.


RE: WPT private instance waterfall error - pmeenan - 04-24-2013 01:18 AM

The purple bar? That is the DOM Content Loaded event (and the width is how long it takes to execute). You will see that on the public instance if you test with Chrome or Firefox as well.

On a jquery site that is usualy all of the javascript code attached to $(document).ready().


RE: WPT private instance waterfall error - jujaehrig - 04-24-2013 08:11 PM

Ok, that's possible.

I indeed made the test with Firefox and my page uses prototype with registered events for "document:ready".

But in the legend purple is "SSL-Negotioation" that's confusing.

And there seem to be other problems as well.

For example request 6-12 having a gap between "Initial Connection" and "Time to First byte".

Is this also Firefox specific and not a bug?


RE: WPT private instance waterfall error - rviscomi - 04-25-2013 04:52 AM

(04-24-2013 08:11 PM)jujaehrig Wrote:  But in the legend purple is "SSL-Negotioation" that's confusing.

That color is used for both SSL Negotiation and domContentLoaded. It does get confusing, but you'll only see SSL Negotiation when it is a component of a particular request (with a padlock icon to the left of the resource name). And you'll know it's domContentLoaded when it spans the entire height of the waterfall.

And it's for both Firefox and Chrome. Not IE 10, though.


RE: WPT private instance waterfall error - jujaehrig - 04-25-2013 10:21 PM

Ok.

Thanks allot Smile


RE: WPT private instance waterfall error - pmeenan - 04-27-2013 11:29 PM

The gap is also normal (and you should see it on the public instance as well). That happens when the browser does a speculative pre-connect before it knows what resources it is going to request.