WebPagetest Forums
IE Agent crashing on Windows XP for version 2.11 - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: IE Agent crashing on Windows XP for version 2.11 (/showthread.php?tid=12217)

Pages: 1 2 3


IE Agent crashing on Windows XP for version 2.11 - braincracking - 04-26-2013 08:51 PM

Hi

I recently upgraded WPT to version 2.11 and since then I have the IE tests (with wptdriver) that keeps being stopped by the Windows DEP (Data Execution Prevention).
I disabled it, IE is crashing.
I modified it to add IE and all agents .exe into the whitelist and I still have the warnings

Other browsers are fine.
It used to work with urlBlast
I'm running it on Windows XP, lastest windows upgrades are made

Did someone encoutered this problem, is there a fix ?


RE: IE Agent crashing on Windows XP for version 2.11 - pmeenan - 04-26-2013 08:55 PM

I haven't seen the issue but I also haven't been using wptdriver on XP for IE much. When are you seeing the DEP warning? Right at launch or in the middle of a test?


RE: IE Agent crashing on Windows XP for version 2.11 - braincracking - 04-26-2013 10:47 PM

at launch, before going to the site.
Note that sometimes, the page is displayed


RE: IE Agent crashing on Windows XP for version 2.11 - pmeenan - 04-27-2013 11:32 PM

I'll try to reproduce it - IE 8, Windows XP 32-bit, VM Ware guest, wptdriver? What is the V icon (think it's VNC but want to be sure)?

Thanks,

-Pat


RE: IE Agent crashing on Windows XP for version 2.11 - braincracking - 04-29-2013 07:41 PM

yes, that's VNC
It's wptdriver, note that the problem does not occur on the same machine with the old urlBlast exe.


RE: IE Agent crashing on Windows XP for version 2.11 - braincracking - 05-10-2013 05:53 PM

did you had the opportunity to test ?


RE: IE Agent crashing on Windows XP for version 2.11 - pmeenan - 05-10-2013 11:23 PM

Yes, sorry for not following up. I've been running wptdriver with IE in every config I can manage and can't seem to reproduce the crash. I'll start releasing debug builds along with the release ones (next one will be a couple of days) and then that should at least help track it down.


RE: IE Agent crashing on Windows XP for version 2.11 - pmeenan - 05-11-2013 02:45 AM

ok, I just did an update to the agents and also did a debug build of them (will try to do that regularly). The debug build is available here: http://www.webpagetest.org/releases/debug/

If you download debugview and run it while the agent is running it should spew all sorts of information about what it is doing: http://technet.microsoft.com/en-us/sysinternals/bb896647.aspx


RE: IE Agent crashing on Windows XP for version 2.11 - braincracking - 05-14-2013 12:40 AM

I copied / pasted all the files I found in the 2 archives in my agent folder. I run a triple test on IE, and here are the logs in debugView :

[2208] [Pagetest] ***** CIEHook::SetSite
[2208] [Pagetest] - Not hooking, wptdriver test is active
[2888] [Pagetest] ***** CIEHook::SetSite
[2888] [Pagetest] - Not hooking, wptdriver test is active
[3608] [Pagetest] ***** CIEHook::SetSite
[3608] [Pagetest] - Not hooking, wptdriver test is active


RE: IE Agent crashing on Windows XP for version 2.11 - pmeenan - 05-14-2013 10:22 PM

Are you sure you grabbed the debug versions of wptdriver.exe and wpthook.dll and that the agent wasn't running when you tried to update? Those messages are from the debug build of pagetest.dll but it isn't active because the test is being run by wptdriver.