WebPagetest Forums
Website test: error, failed to connect - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: Website test: error, failed to connect (/showthread.php?tid=12226)



Website test: error, failed to connect - Barnez - 05-03-2013 08:20 PM

Hi,

I have just launched a site I want to finish optimising through the webpagetest analysis. Initially I was able to test the site fine, however since removing one of the two site calls being made (http://proofscience.com and http://www.proofscience.com) through the wordpress dashboard-general-wordpress/site address settings, I now am unable to test the site here.

The return I receive is, Error, failed to connect http://www.webpagetest.org/result/130503_M6_D7Y/

The strange thing is that I can access the site's frontend, backend and also test it from other platforms. I wonder what could be the issue here? Any ideas would be gratefully received as the breakdown from websitetest is excellent, and sorely missed right now.

Barnez


RE: Website test: error, failed to connect - Barnez - 05-04-2013 04:56 PM

(05-03-2013 08:20 PM)Barnez Wrote:  Hi,

I have just launched a site I want to finish optimising through the webpagetest analysis. Initially I was able to test the site fine, however since removing one of the two site calls being made (http://proofscience.com and http://www.proofscience.com) through the wordpress dashboard-general-wordpress/site address settings, I now am unable to test the site here.

The return I receive is, Error, failed to connect http://www.webpagetest.org/result/130503_M6_D7Y/

The strange thing is that I can access the site's frontend, backend and also test it from other platforms. I wonder what could be the issue here? Any ideas would be gratefully received as the breakdown from websitetest is excellent, and sorely missed right now.

Barnez


When I get a full waterfall, the main theme's style.css is showing as a 404 error. This is strange as the files can be accessed through the direct urls (note that site is using a child theme, and it is the main stylesheet that is showing the errors).

Any ideas why this might be happening?
Barnez

Site
http://www.proofscience.com
http://www.proofscience.com/wp-content/themes/breakout-child/style.css
http://www.proofscience.com/wp-content/themes/breakout/style.css

http://www.proofscience.com/wp-content/themes/breakout/css/theme.css

Waterfall
http://www.webpagetest.org/result/130503_TQ_TN5/1/details/


RE: Website test: error, failed to connect - Barnez - 05-05-2013 07:43 PM

[Resolved]

This was a child theme issue. Using the theme developer's custom child theme setup, as opposed to the Wordpress codex version, has resolved the 404 error.