WebPagetest Forums
Slow In India - Blazing Fast Elsewhere - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Slow In India - Blazing Fast Elsewhere (/showthread.php?tid=12541)



Slow In India - Blazing Fast Elsewhere - bhagwad - 09-11-2013 12:31 AM

I have a large number of Indian visitors to my blog. While I get extremely good tests results when I set the webpagetest location in the US, the speeds for India are horrendous!

Here are the results:

US: http://www.webpagetest.org/result/130910_AA_GWB/

First View: 1.844 seconds

India: http://www.webpagetest.org/result/130910_QT_HTD/

First View: 25.892 seconds!

When I check to see what's holding it up, there are large unexplained gaps in the timeline where nothing seems to be happening. No connection, no download, no waiting.

I would appreciate any insight into what's causing these problems. I have no idea whether these timings are representative of my users in India or a specific issue with the test itself for some reason...


RE: Slow In India - Blazing Fast Elsewhere - bhagwad - 09-13-2013 12:34 AM

A follow up:

It seems to be some kind of issue with the testing infrastructure. I asked some individuals living in India to check out a few pages and they said it was quite fast. Nowhere near the 25+ seconds I'm getting from webpagetest.

I'm very interested to know the cause of this discrepancy.


RE: Slow In India - Blazing Fast Elsewhere - pmeenan - 09-13-2013 05:07 AM

Sorry, it looks like there were serious CPU performance issues with the Delhi VPS. It looks a lot better from the other India test location: http://www.webpagetest.org/result/130912_YP_280dfa3f111d0faa74dce92024baa11e/

I just killed the Delhi location and will look for another provider.


RE: Slow In India - Blazing Fast Elsewhere - bhagwad - 09-13-2013 11:11 AM

(09-13-2013 05:07 AM)pmeenan Wrote:  Sorry, it looks like there were serious CPU performance issues with the Delhi VPS. It looks a lot better from the other India test location: http://www.webpagetest.org/result/130912_YP_280dfa3f111d0faa74dce92024baa11e/

I just killed the Delhi location and will look for another provider.

Ah! Thank you for the explanation Smile