WebPagetest Forums
Joomla slow load - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Joomla slow load (/showthread.php?tid=12852)



Joomla slow load - joseagro - 03-11-2014 09:18 AM

Hello, i have a production site (http://www.materialvertical.es)
First byte is 10 sec (http://www.webpagetest.org/result/140310_A0_14T9/)
I´ve tried everything to improve this data, but there is no way.
Can anyone help me with this?
I guess is a template issue, because if i change the template load time is 2-3 sec, but i would like to maintain this template.
How could i improve this?
Thanks in advance


RE: Joomla slow load - pmeenan - 03-12-2014 12:02 AM

What hosting are you on (shared, VPS, dedicated)?

Most of your resources are coming back fast enough so it looks like the web server itself is doing ok but there's a good chance that you're having a database or other back-end problem.

It looks like it is consistently 10 seconds: http://www.webpagetest.org/result/140311_CB_KBB/ which looks a lot like a timeout somewhere on the back-end. Look through your error logs and see if anything shows up but my bet is that a plugin or the template is making a call to an external service (maybe a geo location check or something like that) and that call is timing out.

If you have root on the system you can install New Relic's php agent which should be able to tell you really quickly exactly what the call is.


RE: Joomla slow load - joseagro - 03-12-2014 12:27 AM

Pmeenan, first of all, thanks for your answer.
Web is in a shared hosting, but server load is not problem, because another web in the hosting has a first byte of 2-3 seconds.

Another question is, results are different making test with Firefox and Chrome:

Firefox:http://www.webpagetest.org/result/140310_A0_14T9/
Chrome http://www.webpagetest.org/result/140310_WM_15HG

I don´t have root on the system, any other idea would be apreciated.


RE: Joomla slow load - pmeenan - 03-12-2014 12:44 AM

Could be that it uses a different code path on the back-end for IE vs Chrome and maybe it's really something that has a 5-second timeout that is getting called twice with IE.

Without root on the server you're basically down to manual debugging to track down the issue:

- Try turning as many plugins off as you can and see if the problem goes away. If so, then turn them on one at a time until you can see where it comes from.

- Try a test with the same plugins but a different template. If it goes away then you need to look through the template code (could be that it's doing a license check of some kind that is timing out).

- Add logging throughout the code to see what operation is taking the time.

You could also clone the site to a local Joomla install where you do have root and debug it there.


RE: Joomla slow load - joseagro - 03-12-2014 06:35 AM

Hello again, i turned off most of plugins at the joomla backend, but first byte is again 10-12 seconds.
How can i do this? -> - Add logging throughout the code to see what operation is taking the time.
Thanks again


RE: Joomla slow load - Anton Chigurh - 04-12-2014 08:59 AM

Your main problem is a fat page. How fast do you expect 1.3 megabytes to load on a browser?

Slim it down, you'll improve performance. Show me a fat page and I'll show you a slow page, every time.

You can save close to 700kb just by optimizing your jpeg images, listed here.

Look how large these images are vs. the size you're scaling them to, in the script.

Images

Optimize and resize them. Make them only a little bit larger in dimension than you're scaling them to render - the full images still load, byte size and all, they're just scaled to look smaller than they actually are.

This stuff isn't rocket science, it's simple common sense really.