WebPagetest Forums
FF giving error on all sites - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: FF giving error on all sites (/showthread.php?tid=12900)



FF giving error on all sites - zaktoo - 04-09-2014 08:27 PM

Hi

I've tried a few instances with the FF user agent and all tried so far give errors. Chrome works fine.

HTH

Ciao

Zak


RE: FF giving error on all sites - pmeenan - 04-09-2014 11:22 PM

Could you link to a test result? Is it a specific location?

Here is a test I just ran from Dulles with Firefox and it loaded fine: http://www.webpagetest.org/result/140409_BT_9eece223f891935ce70a628208f770c3/


RE: FF giving error on all sites - zaktoo - 04-10-2014 12:57 AM

Here you go:
http://www.webpagetest.org/result/140409_R4_MWY/

Thanks for a great service, by the way.


RE: FF giving error on all sites - pmeenan - 04-10-2014 01:01 AM

Looks like you are using an invalid cert (probably a dev cert). You need to go to advanced settings and check the "Ignore SSL Certificate Errors" box - http://www.webpagetest.org/result/140409_KP_aeb82362b3ee6f41be90de1bfca4b9e9/


RE: FF giving error on all sites - zaktoo - 04-10-2014 01:02 AM

It's not an invalid cert (although I'll go and double-check that). Thanks for the pointer though.

Ciao

Zak

Thanks Patrick. The cert itself wasn't invalid, but the intermediate cert wasn't being set by the server, which can cause issues. Adding the intermediate cert to the certificate file solved the problem, in case anyone else hits this particular issue in the future.