WebPagetest Forums
Locations / wptdriver Configuration Help - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: Locations / wptdriver Configuration Help (/showthread.php?tid=13163)

Locations / wptdriver Configuration Help - Linuturk - 08-14-2014 05:01 AM

I'm having a hard time configuring my locations.ini and wptdriver.ini files. Here is what I currently have:

    Time Limit=120
    ;Automatically install and update support software (Flash, Silverlight, etc)
    exe="C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"
    options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'
    exe="C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
    options='-profile "%PROFILE%" -no-remote'
    ;exe="C:\Program Files\Safari\Safari.exe"
    exe="C:\Program Files\Internet Explorer\iexplore.exe"

    ; These are the top-level locations that are listed in the location dropdown
    ; Each one points to one or more browser configurations
    ;label="WebPagetest.org - Dulles, VA"
    ; These are the browser-specific configurations that match the configurations
    ; defined in the top-level locations.  Each one of these MUST match the location
    ; name configured on the test agent (urlblast.ini or wptdriver.ini)
    ;browser=IE 8
    ;label="Test Location - IE 8"
    ; For a wptdriver configuration (chrome, firefox), the browser labels here
    ; MUST match the labels used in wptdriver.ini
    ;label="Test Location"

I'm seeing a GET request hitting the web server, so it seems everything is functioning correctly, except for the configuration.


Any ideas?

RE: Locations / wptdriver Configuration Help - Linuturk - 08-15-2014 01:39 AM

I figured this one out, and I wanted to share so everyone would benefit.

My secret key had an '&' character in it, and it was breaking the request made by the wptdriver software. Removing this character allowed it to connect.