WebPagetest Forums
Large disparity between results from Toronto vs other locations - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Large disparity between results from Toronto vs other locations (/showthread.php?tid=13187)



Large disparity between results from Toronto vs other locations - petertoi - 08-22-2014 02:30 AM

Hi there,

I'm struggling to understand why I'm having such a large disparity (27+ secs vs 4 secs) in first-time load between requests run from Toronto vs Montreal (and other NA locations) on webpagetest.org. The website in question is hosted by VPS.net in their Atlanta data centre. I have also observed the same speed disparity (60+ mins vs 1.5 mins) while running a standard 100 mb download test using curl and ftp from my own PC here in Toronto as well as test machines in Montreal so I'm fairly confident the issue isn't with the webpagetest.org host itself.

Toronto: http://www.webpagetest.org/result/140812_EW_13H4/
Montreal: http://www.webpagetest.org/result/140812_DG_13H7/
California: http://www.webpagetest.org/result/140821_TF_R4P/

Can any of you fine folks suggest a few steps I can take to get to the bottom of this? I've engaged the hosting company but they don't seem to have any answers besides migrating the virtual machine to another VM host or data centre. My research has shown that webpagetest.org Toronto is using Cogeco and I'm using Bell Internet so it's probably not an ISP issue on this end.

I'm also noticing a similar speed disparity (40 secs vs 5 secs) for a site hosted in Texas which leads me to believe that this is not a hosting issue but rather a routing issue? But honestly I don't know.

Toronto: http://www.webpagetest.org/result/140821_8Y_QF2/
Montreal: http://www.webpagetest.org/result/140821_4R_QEG/
California: http://www.webpagetest.org/result/140821_96_R4J/

Has anyone else noticed issues with transfer speeds from locations in the US to clients in Toronto?

Any and all advice is welcome!

Thanks,
Peter


RE: Large disparity between results from Toronto vs other locations - gregdseymour - 08-24-2014 04:02 AM

Having the same issue. Have yet to see a reason for why the load times are so high when testing from Toronto.

(08-22-2014 02:30 AM)petertoi Wrote:  Hi there,

I'm struggling to understand why I'm having such a large disparity (27+ secs vs 4 secs) in first-time load between requests run from Toronto vs Montreal (and other NA locations) on webpagetest.org. The website in question is hosted by VPS.net in their Atlanta data centre. I have also observed the same speed disparity (60+ mins vs 1.5 mins) while running a standard 100 mb download test using curl and ftp from my own PC here in Toronto as well as test machines in Montreal so I'm fairly confident the issue isn't with the webpagetest.org host itself.

Toronto: http://www.webpagetest.org/result/140812_EW_13H4/
Montreal: http://www.webpagetest.org/result/140812_DG_13H7/
California: http://www.webpagetest.org/result/140821_TF_R4P/

Can any of you fine folks suggest a few steps I can take to get to the bottom of this? I've engaged the hosting company but they don't seem to have any answers besides migrating the virtual machine to another VM host or data centre. My research has shown that webpagetest.org Toronto is using Cogeco and I'm using Bell Internet so it's probably not an ISP issue on this end.

I'm also noticing a similar speed disparity (40 secs vs 5 secs) for a site hosted in Texas which leads me to believe that this is not a hosting issue but rather a routing issue? But honestly I don't know.

Toronto: http://www.webpagetest.org/result/140821_8Y_QF2/
Montreal: http://www.webpagetest.org/result/140821_4R_QEG/
California: http://www.webpagetest.org/result/140821_96_R4J/

Has anyone else noticed issues with transfer speeds from locations in the US to clients in Toronto?

Any and all advice is welcome!

Thanks,
Peter



RE: Large disparity between results from Toronto vs other locations - beekvang - 08-25-2014 12:48 AM

I've similar issues although not from Toronto. My ISP is located in Utah. It takes 3 seconds to complete the document when using the server in Los Angeles and 35 seconds when using the server in Phoenix. I'm not sure why that is.