WebPagetest Forums
Page loading successfully but results unavailable - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: General Discussion (/forumdisplay.php?fid=25)
+--- Thread: Page loading successfully but results unavailable (/showthread.php?tid=13196)



Page loading successfully but results unavailable - nccgroup_avi - 08-26-2014 10:39 PM

Hello everyone,

Whilst trying to build the following user journey using WPT scripting, I found the last step bit tricky. On my private instance I see the browser loading the page correctly, however WPT doesn't capture the results (of step=10). All the other steps look fine except step=10.

Result is here: http://www.webpagetest.org/result/140821_HZ_d79b81080d7eeccb3fac0d2f0d49af18/

Here is the user journey that I was trying to build:

1. Visit http://www.avis.co.uk
2. Set the search textbox value to 'LHR'
3. Load suggested results of airports
4. Click on first airport
5. Click on 'Choose this Location'
6. Select Date (anything in future)
7. Select Time (leave the default value)
8. Click on 'Search for cars'
9. Click on Choose
10. Continue to 'Review your booking'

Also see the code below:

Code:
// remember to tick the 'Ignore SSL Certificate Errors' checkbox under Advanced tab

combineSteps
navigate    http://www.avis.co.uk
execAndWait    $('#hire-search').focus();
execAndWait    $('#hire-search').val('LHR');
execAndWait    $('#hire-search').trigger('keyup');
execAndWait    document.getElementsByClassName('flyout-name-content')[0].click();
execAndWait    document.getElementsByClassName('select-location')[0].click();
execAndWait    document.getElementsByClassName('ui-state-default')[30].click();
execAndWait    document.getElementsByClassName('additional-control')[0].click();
execAndWait    document.getElementById('car-search-submission1').click();
sleep    5
execAndWait    document.getElementsByClassName('continue')[1].click();
execAndWait    $('#packages-submit').trigger('click');
sleep    2

Any suggestions on how I can get the results of last step in WPT?

Thanks,
Avi


RE: Page loading successfully but results unavailable - pmeenan - 08-30-2014 01:24 AM

Which browser and are you using the latest wptdriver? Main reason I ask is that I made a bunch of changes a few weeks ago to improve the exec* support (particularly for chrome). Before it was running in a sandbox and didn't have access to things like JQuery. Now it should be using the same interface that dev tools does.

If you run the same commands in the F12-dev tools console does it work?

You also have a lot of "andwait" commands. Do all of those actions trigger navigation? You should use "exec" commands for the ones that just interact locally with the UI and save the "andwait" commands for things that generate network activity and have to wait for something to come back.


RE: Page loading successfully but results unavailable - nccgroup_avi - 09-02-2014 01:34 AM

The browser we are using is Chrome. Also I have tried in recent public WPT.

Yes, I have tried all the commands in F12-dev tools console and it works fine.

Also I have taken off few "andWait" and retained only the ones that need them, here is the result:
http://www.webpagetest.org/result/140901_CA_c6c668c28a13ddfe1dd268ecfda2bdbf/

Unfortunately, the results of last step is still not logged.