WebPagetest Forums
markUserTime - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: markUserTime (/showthread.php?tid=13215)



markUserTime - TheDoc - 09-04-2014 11:50 PM

Hi all

I'm looking at using the markUserTime function added to WPT, and have read the notes at http://blog.patrickmeenan.com/2013/07/measuring-performance-of-user-experience.html.

I thought of looking at a website that already has this implemented so I could run a test on the webpagetest.org.uk site and see the results before I start implementing it myself. I found that vestatalentagency.kinja.com has a number of these in the webpage, so ran a test but the results do not show the User Time or the individual marks that I was expecting to see - http://www.webpagetest.org/result/140904_V0_78be080d7e14a6321014314c5a890b0c/.

Is there a reason why this is? It would help to know if there is more that needs doing in order to see the expected User Times in the results.

Thanks

Steve


RE: markUserTime - pmeenan - 09-05-2014 12:09 AM

When you load the page manually in Chrome, try opening dev tools and put this in the console:

window.performance.getEntriesByType("mark");

If the page really instrumented anything, you would get the marks. I didn't get anything. It's also possible that they cleared them out using clearMarks() after reporting them which would prevent WPT from being able to fetch them.

FWIW, WebPagetest itself has it implemented. The more interesting pages are:

Test details page: http://www.webpagetest.org/result/140904_TB_7032e5233bdbe9b9d344c5c1aecb05de/1/details/

Content breakdown: http://www.webpagetest.org/result/140904_QP_ac0c8eedffafbdcbf7509d2e2eda2d36/1/details/


RE: markUserTime - TheDoc - 09-09-2014 12:17 AM

Thanks Patrick.

I had a look at the WPT home page and can see where they are added - time to give it a go on our site!

Steve