WebPagetest Forums
Testing test runs on private servers - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: Testing test runs on private servers (/showthread.php?tid=13470)



Testing test runs on private servers - flickFlackJack - 01-10-2015 08:55 AM

Hello all,

I am trying to test the work/getwork.php from the AMI of the webpagetest server.

AMI: ami-fcfd6194
Region: us-east-1

I have a few questions on how to test the server and the spin up of servers

1. How would I go about testing the test runs and making sure it display the webpages? So far based on what I gathered from parts of the forum.

To get tests
php www/work/getwork.php

To run tests from queue:
php www/runtest.php

Any particular order I need to do to manually run the tests? Also how would I send the results back to the user who ran the test?

2. There's a warning popping up for www/work/getwork.php saying this even though I installed php pear:

PHP Code:
PHP Warning:  include(common.inc): failed to open streamNo such file or directory in /var/www/webpagetest/www/work/getwork.php on line 14
PHP Warning
:  include(): Failed opening 'common.inc' for inclusion (include_path='.:/usr/share/php:/usr/share/pear'in /var/www/webpagetest/www/work/getwork.php 

Is there a different library I need or I need to setup the library paths to php pear?


RE: Testing test runs on private servers - flickFlackJack - 01-10-2015 10:02 AM

Another question.

What script spins up the AMI agents when there is work in the queue? Or there has be an instance of the test agent running


RE: Testing test runs on private servers - flickFlackJack - 01-10-2015 11:22 AM

I narrowed down the problem and found in the error logs that I am not authorized to perform the operation when getting the list of running ec2 instances from ec2.inc.php.

Do I need to make create my own AMIs from the community AMIs or can I actually use the community AMIs to generate my own private instances for testing?


RE: Testing test runs on private servers - pmeenan - 01-13-2015 02:09 AM

You can use the community AMIs. The permission problem is likely caused by the permissions of your EC2 API key that you are using. You need to make sure it has most of the EC2 permissions (list instances, terminate instances, launch instances).


RE: Testing test runs on private servers - flickFlackJack - 01-14-2015 11:18 AM

Thanks. I tried to do a custom policy, but looks like I missed some of the policy rules to allow the server to manage the test agents. Went with a general ec2 management policy instead.