WebPagetest Forums
How to run tests for IE 11 Dulles Cable - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: General Discussion (/forumdisplay.php?fid=25)
+--- Thread: How to run tests for IE 11 Dulles Cable (/showthread.php?tid=13560)



How to run tests for IE 11 Dulles Cable - parag.paul - 02-24-2015 02:07 PM

hi,
location Dulles_IE9 is the only one that is working if I run the Webpagetest Rest API. It says the following for IE 11
"The test failed to run.Invalid browser selected IE 11. Same with IE 10.
http://www.webpagetest.org/result/150224_EY_b86a7dd3bbb06d5be56226b40c428073/

My request is like this
http://www.webpagetest.org/runtest.php?f=xml&fvonly=0&private=1&timeline=1&timelineStack=1&runs=1&location=Dulles_IE11&video=1&k=<something>&script= xxxxx

script is correct . I did not paste it since it is underproduction. The Dulles_IE9 is the only one that is working. How do I get it working for IE11


RE: How to run tests for IE 11 Dulles Cable - pmeenan - 02-24-2015 11:39 PM

First - don't ever post your API key in public. I've edited your post to remove it but by doing that you are basically making it available for anyone else who would want to use it.

As far as the locations go, the automatically generated API keys have a restricted set of locations that they are allowed to use. I just added the IE 10 and IE 11 locations to the list but there are fewer test agents and if the backlogs start to get too long I'll have to remove them again (or maybe rebalance the number of IE 9 test machines). It should work if you try now.