WebPagetest Forums
In need of expert advice - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: In need of expert advice (/showthread.php?tid=13852)



In need of expert advice - smjure - 08-05-2015 10:39 PM

Dear Experts

Am unprofessional in web design but have made the following page myself with, I believe, quite good results:
http://www.webpagetest.org/result/150805_JM_K0T/1/details/

Even though TTFB gets "F", I think it is still good. What bothers me is that despite using CDN, more than 3 seconds elapse between TTFB and "Start Render". Secondly I am noticing some time gaps occurring, e.g. usually at "http://cdn.jsenergy.si/wp-includes/js/wp-emoji-release.min.js" like here:
http://www.webpagetest.org/result/150805_JM_K0T/1/details/

Kindly advice me what could I do more to improve time between TTFB and "Start Render" and possibly remove the time gaps?

Thanks for any advice
Smjure


RE: In need of expert advice - ajm_76 - 08-05-2015 11:25 PM

Hi smjure,

20 blocking script resources and 8 blocking CSS resources. Until you get these whittled down to as few as possible (ideally none), all of the site's key, user-experience-centered performance metrics will suffer.

Be well,
AJ
Managing Partner
WpFASTER | WordPress Optimization


RE: In need of expert advice - chelvan - 08-06-2015 03:39 AM

Also on lines 43-48 you have a number of external fonts. These can block text rendering. Are all these scripts needed for the home page render? Think about which scripts are unnecessary as AJ points out. For example, some of the scripts such as jqueryform.js printfriendly.js are probably unnecessary for first render.


RE: In need of expert advice - smjure - 08-06-2015 08:03 PM

Thank you both. I did play with it and achieved some further improvements:
http://www.webpagetest.org/result/150806_PW_HKZ/
http://www.webpagetest.org/result/150806_2H_FN7/

I think it is quite good already. I managed to reduce .js scripts from 20 down to 12, but could not reduce number of .css as visual problems emerge. I also set up asynchronous loading for queryform.js, printfriendly.js...

Still there are time gaps appearing. Could it be because of slow CDN content loading (it appears quite high loading time in both links)? At the time gap the file ".../wp-includes/js/wp-emoji-release.min.js" appears which could maybe also be problematic?

Any further comment and advices very much appreciated. Thank you kindly!


RE: In need of expert advice - Anton Chigurh - 08-07-2015 10:58 AM

The poor grades for TTFB are due to the WPT itself, assigning a ridiculously low target based on use of a CDN. Patrick acknowledges this and says he will be addressing it. Here's yours:

Quote:First Byte Time (back-end processing): 67/100

414 ms First Byte Time
90 ms Target First Byte Time
That target is just a silly number. Therefore it is safe for you to ignore the D and F grades for TTFB.

And just, dump cloudflare. Get off its nameservers. It doesn't improve performance.


RE: In need of expert advice - smjure - 08-07-2015 08:36 PM

Smile I will dump it as suggested. Thank you very much all for your comments!