WebPagetest Forums
Images N/A - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: Images N/A (/showthread.php?tid=14153)



Images N/A - nsilverman - 01-07-2016 11:36 AM

I'm confused about the images showing up as N/A. I've read a few other posts where it appeared that maybe the images were getting served via gzip, however I don't see that happening for us and I'm confused as to why we don't get results for that column. Maybe I'm overlooking something or somehow testing it incorrectly?

This test result shows N/A for "Compress Images":

http://www.webpagetest.org/result/160107_QW_32S/

Line 30 of the First View shows this URL:

https://www.chooseenergy.com/wp-content/uploads/2015/03/StockPhotography-Final-135.jpg

When I curl that URL I see Content-Type: image/jpeg and I don't see any Content-Encoding: gzip.

Am I somehow overlooking something here? Shouldn't I be seeing a grade for all the .jpg and .png URLs on that page load?

Thanks in advance,

Nate


RE: Images N/A - lbennett - 01-08-2016 02:01 AM

If you want more details around image defects including the optimized files you should try this free tool: https://zoompf.com/free


RE: Images N/A - pmeenan - 01-08-2016 11:16 PM

WPT doesn't have access to the response bodies for HTTPS resources on Chrome (yet - should have a solution this month) so the image check won't work in that case.