WebPagetest Forums
More slow from chrome at second load - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Optimization Discussions (/forumdisplay.php?fid=5)
+--- Thread: More slow from chrome at second load (/showthread.php?tid=14372)



More slow from chrome at second load - triplexita - 06-13-2016 06:53 AM

Hi
I have checked more and more time my website from more server but i don't understand because i everytime have more long time in second load with chrome ....

Sample checking from frankfurt firefox. 1st load first byte 0.4 ... Second load 0.2
When checking from chrome first byte 0.5 second loading 1.8 why this where are the problem for thiss slow loading in chrome ?

Check yourself where are my error?

http://www.webpagetest.org/result/160612_9W_YPN/

This from frankfurt ....with firefox
http://www.webpagetest.org/result/160612_XB_YR0/


RE: More slow from chrome at second load - rviscomi - 06-14-2016 04:54 PM

In your Firefox test, there are two redirects: http to https (requests #1 and #4) and another redirect to www (requests #4 and #5). See http://www.webpagetest.org/result/160612_XB_YR0/1/details/

WPT seems to be marking the first byte time for request #2, which is an intermediary step in the SSL negotiation. Your site hasn't actually returned any useful bytes, however. That doesn't happen until request #5 at about 1.5 seconds, which is very similar to your Chrome numbers. In first/repeat view in both browsers, your server is really slow to respond to the initial request. It's not that Firefox is faster, it's just that WPT is incorrectly reporting the first byte time. I filed https://github.com/WPO-Foundation/webpagetest/issues/640.

And the first byte time shouldn't be affected by first/repeat views. The fact that Chrome's repeat view is slightly slower (~150ms) is probably not significant and just shows that your server has slow and inconsistent response times. Try running the same test with multiple runs and see if the time varies by 100-200ms. This could happen if you're on shared hosting. There could also be some inefficiencies on your backend. Use tools like New Relic to track down server-side performance issues.


RE: More slow from chrome at second load - triplexita - 06-14-2016 05:18 PM

Yes this is exact .... but why in chrome the second load are always long that the first ... the first load 1241 ms ... the second 1720 ms ???

http://www.webpagetest.org/result/160614_5D_CQB/


(06-14-2016 04:54 PM)rviscomi Wrote:  In your Firefox test, there are two redirects: http to https (requests #1 and #4) and another redirect to www (requests #4 and #5). See http://www.webpagetest.org/result/160612_XB_YR0/1/details/

WPT seems to be marking the first byte time for request #2, which is an intermediary step in the SSL negotiation. Your site hasn't actually returned any useful bytes, however. That doesn't happen until request #5 at about 1.5 seconds, which is very similar to your Chrome numbers. In first/repeat view in both browsers, your server is really slow to respond to the initial request. It's not that Firefox is faster, it's just that WPT is incorrectly reporting the first byte time. I filed https://github.com/WPO-Foundation/webpagetest/issues/640.

And the first byte time shouldn't be affected by first/repeat views. The fact that Chrome's repeat view is slightly slower (~150ms) is probably not significant and just shows that your server has slow and inconsistent response times. Try running the same test with multiple runs and see if the time varies by 100-200ms. This could happen if you're on shared hosting. There could also be some inefficiencies on your backend. Use tools like New Relic to track down server-side performance issues.