WebPagetest Forums
firstPaint on Firefox - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: General Discussion (/forumdisplay.php?fid=25)
+--- Thread: firstPaint on Firefox (/showthread.php?tid=14413)



firstPaint on Firefox - kzarifis - 07-22-2016 05:05 PM

Is there a way to get the firstPaint reported by Firefox (does FF even export it in the HAR) ? All Firefox HARs I'm looking at (both from a private and public instances), have ["log"]["pages"]["_firstPaint"] == 0 . Is that the right place to try to extract it from?

Also a relevant question regarding StartRender (which is consistently reported from all browsers) : Since (as far as I know) it is based on captures of 100ms intervals, what does the fact that it's not always multiples of 100 mean? Does the timer start when the browser is opened / when the navigation starts? And in case of a WPT script, does it start at one of those times, or can "logData 0/1" affect it?

Thanks!


RE: firstPaint on Firefox - pmeenan - 07-26-2016 11:30 PM

firstPaint is extracted from within the page through javascript APIs and provides a way for you to compare the video-based start render with what the browser reports (and what you can use for RUM reporting). Firefox doesn't expose any paint timing information to the DOM so there is no firstPaint metric for it.

The startRender is built on top of video frames captured every 100ms but since the capture interval isn't perfect, the frames are recorded at the actual time they were captured.