WebPagetest Forums
IE11 starts with about:blank - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: IE11 starts with about:blank (/showthread.php?tid=14435)



IE11 starts with about:blank - Kevin Tierney - 08-03-2016 07:02 AM

When IE11 starts on the test agent just fine (wptdriver ver 291) but it doesn't use the URL to be tested. It always starts with about:blank. The command that appears in the wptdriver display is:

"C:\Program Files\Internet Explorer\iexplore.exe" about:blank

And the server then reports the test timed out waiting for the browser to start. The tests run fine for Chrome and Firefox. Thanks.


RE: IE11 starts with about:blank - pmeenan - 08-03-2016 07:25 AM

My guess is that it is a 64-bit version of Windows and the path is pointing to the 64-bit IE. It needs to point to the 32-bit one in Program Files x86


RE: IE11 starts with about:blank - Kevin Tierney - 08-05-2016 11:30 PM

I'm now getting the same timeout behavior from Firefox as from IE11. Chrome works fine. The wptdriver window on the test agent shows that the URL being used is about:blank.html, or using the webpagetest API, http://127.0.0.1:8888/blank.html. I don't think wptdriver.exe is picking up the URL under test for some reason. Perhaps my wptdriver.ini and/or location.ini files (below) are in error. Thanks for your help.

location.ini:
-----------

[locations]
1=Test_loc
2=Public_Dulles
default=Test_loc

;
; These are the top-level locations that are listed in the location dropdown
; Each one points to one or more browser configurations
;

[Test_loc]
1=webpagetestserver
label=Akamai Tester
group=Desktop

[Public_Dulles]
1=WPT_Dulles_IE9
2=WPT_Dulles_IE10
label="WebPagetest.org - Dulles, VA"
group=Public

;
; Tese are the browser-specific configurations that match the configurations
; defined in the top-level locations. Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)
;

[webpagetestserver]
browser=Chrome,Firefox,IE11
latency=0
label="Akamai Tester"
connectivity=LAN

[IE11]
browser=IE 11
latency=0
label="Akamai Tester - IE 11"

;
; For a wptdriver configuration (chrome, firefox), the browser labels here
; MUST match the labels used in wptdriver.ini
;

[Chrome]
browser=Chrome
label="Akamai Tester - Chrome"

[Firefox]
browser=Firefox
label="Akamai Tester - Firefox"
;
; This is an example of a "remote" configuration where tests can be proxied to a remote
; webpagetest instance. The test will be run by the remote server but the results
; will be downloaded to the local server and deleted from the remote agent
;
; Each location that you want to use from the remote server needs to be configured
; individually on the local configuration (location names do not need to match)
;
; To use the public webpagetest.org instance you will need an API key
;

[WPT_Dulles_IE9]
browser=IE 9
label="WebPagetest.org Dulles, VA - IE9"
relayServer="http://www.webpagetest.org/"
relayKey=<key>
relayLocation=Dulles_IE9

; KTT - Added to test
[WPT_Dulles_IE10]
browser=IE 10
label="WebPagetest.org Dulles, VA - IE10"
relayServer="http://www.webpagetest.org/"
relayKey=<key>
relayLocation=Dulles_IE10

--------------------------------------------------------------------------------

wptdriver.ini:
------------

[WebPagetest]
url=<server_address>
location=webpagetestserver
Time Limit=120
;Automatically install and update support software (Flash, Silverlight, etc)
software=http://www.webpagetest.org/installers/software.dat

[Chrome]
exe="C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"
;options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --ignore-certificate-errors'
installer=http://www.webpagetest.org/installers/browsers/chrome.dat

[Firefox]
exe="C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
options='-profile "%PROFILE%" -no-remote'
installer=http://www.webpagetest.org/installers/browsers/firefox.dat
template=firefox

[Safari]
exe="C:\Program Files\Safari\Safari.exe"

[IE11]
exe="C:\Program Files\Internet Explorer\iexplore.exe"


RE: IE11 starts with about:blank - pmeenan - 08-06-2016 12:07 AM

What version of wptdriver and what version of Firefox? Firefox 48 just rolled out and requires extensions to be signed so you need to be running wptdriver 297 or later: https://www.webpagetest.org/forums/showthread.php?tid=14436


RE: IE11 starts with about:blank - Kevin Tierney - 08-08-2016 11:16 PM

Just installed ver. 299 of wptdriver. Chrome and Firefox are now working fine. But testing on IE11, 32-bit, still times out on the about:blank page. Thanks for the update.


RE: IE11 starts with about:blank - pmeenan - 08-08-2016 11:18 PM

Try launching IE manually and go to tools->manage add-ons and make sure the WebPageTest plugin is enabled.