WebPagetest Forums
Elusive 12999 error code - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Elusive 12999 error code (/showthread.php?tid=14452)

Elusive 12999 error code - pkallberg - 08-12-2016 07:48 PM

Hey guys,

I've been receiving reports from several Android Chrome users that they're not able to visit our site, and I'm glad I found this tool. WebPageTest is showing a 12999 error code which is proving quite elusive.

Initially I thought this was due to our RapidSSL certificate, but a SSL Labs test [0] scores an A rating and I'm seeing the same result on both HTTP and HTTPS.

Please see the test results for both protocols [1][2] with 3 runs to avoid outliers, and would appreciate any pointers. I have not been able to replicate this locally with Chrome Dev Tools and as far as I can tell our DNS is setup properly.

Any suggestions?

[0]: https://www.ssllabs.com/ssltest/analyze.html?d=sainloevents.eatabout.co&hideResults=on
[1]: https://www.webpagetest.org/result/160812_8C_28a2fd6b3f3b6e99a180e44d430b3f04/
[2]: https://www.webpagetest.org/result/160812_4M_a848522c15b8724b2f397e8142052d59/

RE: Elusive 12999 error code - pkallberg - 08-15-2016 07:32 PM

I seem to have found the issue behind this problem - one of the CNAMEs on the domain was "app.rsvp--2-.c66.me", and changing this to "app.rsvp.c66.me" has solved the problem.

Does Android Chrome perhaps have issues with "--" in DNS?