WebPagetest Forums
[iOS Agent] Video Capture + Scores - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: [iOS Agent] Video Capture + Scores (/showthread.php?tid=14592)



[iOS Agent] Video Capture + Scores - Eisworld - 11-10-2016 10:02 PM

Hi dears,
I set up correctly my iOS Agent e my Server. Everything works well except if I run command with --processvideo yes, videos are not uploaded.

I think that my configuration is ok because running "python visualmetrics.py --check" the result is OK for everything.

Any ideas?

Another question is about Scores. When the test is finished, in the XML I can't find scores about analyzed page.

Attached screenshot.

Thanks,
Emanuele


RE: [iOS Agent] Video Capture + Scores - pmeenan - 11-12-2016 09:03 AM

Scores are only available on the desktop agents right now.

For video, what kind of phone, what OS and what OS version is on the Mac? If you open quicktime and start a new recording, is the iPhone listed as an available device to record video from?

Video needs to be connected with a lightning cable to a recent version of OSX and iOS 8+ where video recording support was first enabled.


RE: [iOS Agent] Video Capture + Scores - Eisworld - 11-18-2016 02:04 AM

(11-12-2016 09:03 AM)pmeenan Wrote:  Scores are only available on the desktop agents right now.

Ok.

(11-12-2016 09:03 AM)pmeenan Wrote:  For video, what kind of phone, what OS and what OS version is on the Mac? If you open quicktime and start a new recording, is the iPhone listed as an available device to record video from?

Video needs to be connected with a lightning cable to a recent version of OSX and iOS 8+ where video recording support was first enabled.

iPhone 5 SE, jailbroken, iOS 9.3.2
MacBook Air OSX 10.11.5
If I open QuickTime, the video from the iPhone works well.

In the runtmp folder the video was created correctly.

UPDATE:
On my server, screenshots are uploaded correctly but in XMLResult does not compare VIDEO tag.
here you can see the XML: http://54.247.68.98:8181/xmlResult/161117_PB_39/

Thanks,